tutorial data visualization

Hannes's Avatar


18 Nov, 2012 11:21 AM

Good evening,

I started the tutorials on data visualization for Nodebox 3, on Windows 7 (http://nodebox.net/node/documentation/using/data-visualization.html). The one on cost went well. And while the exercise with earthquakes is similar at start, it doesn't seem to work. I import the csv, kept the delimiter on default "," but the Nodebox seems to think everything is in one category, the first one "Src". So if I do a lookup, it only works for Src, and then it gives everything. The other categories aren't recognized. I tried with other delimiters like space or ";" but that doesn't work either. What am I doing wrong here?

Great program btw, I am really loving it.

  1. Support Staff 1 Posted by lievenmenschaer... on 20 Nov, 2012 05:59 PM

    lievenmenschaert's Avatar


    Both csv files have the same structure, you should not change the delimiter. Could you give some more information about how your csv file looks: are commas used to separate the values?

    i included the orginal file as well. Maybe you should try it with that one.


  2. 2 Posted by Hannes on 21 Nov, 2012 05:00 PM

    Hannes's Avatar

    Good evening,

    Both files have the same structure indeed, so thats why I don't understand why it would work with the first one, but not with the second one. I only tried changing the delimiter after realizing the default option did not work.
    I had no problems with my own excel files, just the one from earthquakes. So it's not that big of an issue if I can't solve it.

    As you see in the attached screenshot, Nodebox only recognizes the first category Src and places everything in that category Src="x,x,x,x" instead of Src="x",cat2="x",cat3="x". I did not change anything. I just imported the csv you gave me, and did a lookup to make sure the other categories weren't recognized. The delimiter is still on comma, and the excel file also uses the comma.

    Please don't break your head on this one. I'm just reporting it for a possible bug. It's probably me being stupid though.

    With kind regards,

  3. Support Staff 3 Posted by Frederik De Ble... on 22 Nov, 2012 09:19 AM

    Frederik De Bleser's Avatar

    In what language is your Windows machine?

  4. 4 Posted by hannes on 22 Nov, 2012 01:01 PM

    hannes 's Avatar

    It is in Dutch.

  5. lievenmenschaert closed this discussion on 08 Jan, 2013 10:21 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

30 Nov, 2023 08:38 PM
29 Nov, 2023 01:33 PM
29 Nov, 2023 05:30 AM
28 Nov, 2023 10:03 PM
28 Nov, 2023 12:38 AM


27 Nov, 2023 04:40 AM
26 Nov, 2023 10:02 AM
22 Nov, 2023 09:33 AM
20 Nov, 2023 08:54 PM
17 Nov, 2023 01:43 AM
15 Nov, 2023 06:58 AM