Option Drag Bug

john's Avatar


03 Mar, 2019 06:55 AM


I hit this bug fifty times a day and it's driving me capital K Krazy!

Pick any node and option-drag it to create a copy. The copy will now be selected. If you option-drag Rect1 you will see Rect1 and Rect2 with Rect2 selected.

Now change parameters on the new selected node. All seems normal. But the changes you are making are actually applied to the unselected node you copied from! You think you are changing Node 2 but you really changing Node 1. This violates the whole concept behind selecting things.

This violation happens with all kinds of nodes, including subNetworks. If you don't catch it right away, the damage can be extensive. Not only do the changes you made to the selected node not appear there (leading to all sorts of mysterious behavior), but those changes quietly appear instead in another node, maybe in another area of the screen, that is already connected to many other nodes. This triggers an avalanche of unexpected changes.

There is a simple workaround. After you option-drag you just have to click on some other node to select it, then re-select the new node you just created. The problem is, even after years of this, I keep forgetting to do it. I sometimes get so caught up that I am selecting groups of nodes, option dragging them, and repeating it several times until I notice that my entire network is now completely scrambled.

Please fix this! Please! My sanity - already precarious - hangs in the balance.


  1. Support Staff 1 Posted by john on 16 Jun, 2019 11:18 PM

    john's Avatar


    Could you please take a look at this? It's probably an easy bug to fix and it's still biting me every single day. This is the top bug fix on my list.



  2. Support Staff 2 Posted by john on 15 Jan, 2021 03:24 PM

    john's Avatar

    UPDATE. This bug has been fixed with version 3.0.52. You can download it here:


    Thanks, Frederik!

  3. 3 Posted by rougeux on 15 Jan, 2021 05:19 PM

    rougeux's Avatar

    Wonderful news to hear about option-drag being addressed but now it appears option-drag is disabled completely.

  4. Support Staff 4 Posted by Frederik De Ble... on 15 Jan, 2021 07:39 PM

    Frederik De Bleser's Avatar

    Weird — I just tried it without any issues. Are you on Mac or Windows? Which version?

  5. 5 Posted by rougeux on 15 Jan, 2021 08:06 PM

    rougeux's Avatar

    I'm on macOS 11.1. Anything else I can do to troubleshoot?

  6. Support Staff 6 Posted by john on 15 Jan, 2021 08:33 PM

    john's Avatar

    I am on macOS 10.15.6 and have had no issues with option drag. I believe Frederik is on macOS 11. Very strange.

    Can anyone else out there confirm that option drag is either working or not working for them under NodeBox 3.0.52?

  7. Support Staff 7 Posted by john on 16 Jan, 2021 02:57 AM

    john's Avatar

    Hi Rougeux,

    Some troubleshooting questions and suggestions...

    Were you able to confirm that option drag was working for you on 3.0.51 and only stopped when you upgraded? Can you switch back to 3.0.51 and verify?

    Have you observed problems with option drag anywhere other than Nodebox (e.g. in Finder, Word, Illustrator, etc.)?

    Have you tried rebooting your Mac?

    I did a google search on "Option Drag Not Working" and found this problem occurs for many people in many situations for many different reasons. Sometimes a third party plugin is to blame. One person said shutting down Firefox solved his copy drag issue in other apps (possibly due to a Firefox plugin). Another person reported that his keyboard input somehow got set to a British keyboard instead of an American one; switching back to American keyboard solved the problem.

    Please keep us posted. I'd like to get to the bottom of this and find out if you are the only one experiencing this issue.


  8. 8 Posted by rougeux on 16 Jan, 2021 03:06 AM

    rougeux's Avatar

    Happy to help.

    - Rebooting didn't fix the issue.
    - Closing all other apps didn't fix the issue.
    - Keyboard input is set to U.S. (default)
    - Tried downgrading to 3.0.51 and option-drag works with the same buggy behavior.

    Lucky me if I'm the only one experiencing the issue. :)

  9. Support Staff 9 Posted by john on 16 Jan, 2021 03:14 AM

    john's Avatar

    Stranger and stranger.

    I put out a call to one of my contacts to test this out on her machine. If anyone out there is reading this thread, please reply and say

    • "Option drag works for me under 3.0.52" OR

    • "Option drag stopped working for me when I upgraded to 3.0.52"

    and please indicate what OS you are running under. If this is happening to anyone else maybe we can find what you have in common.

  10. Support Staff 10 Posted by john on 16 Jan, 2021 03:40 AM

    john's Avatar


    What happens when you option drag? Does it just ignore you, or does it drag the node without duplicating it, or something else? I suppose you've already tried holding down the option key for longer before you start the drag.

    Here is a long shot thing to try just to find more clues...

    Go to Keyboard under Mac System Preferences, under the Keyboard tab in the lower right corner click the Modifier Keys button, and remap your Caps Lock Key so that it performs an Option action instead of a Caps Lock. You can then use your Caps Lock key instead of your Option key. Try Caps Lock dragging (hold down Caps Lock and drag rather than just clicking on Caps Lock). After the test you can switch back again to normal.

    I would be very surprised if this worked, but you never know. If it did, that would be a clue.

    I'll keep thinking of other (increasingly desperate) things you might try.


  11. 11 Posted by seohyo on 16 Jan, 2021 10:17 AM

    seohyo's Avatar

    Option-drag works nicely for me under 3.0.52 / Catalina 10.15.5.
    Thank you and Frederik so much for all the things for Nodebox community:)


  12. Support Staff 12 Posted by john on 16 Jan, 2021 04:26 PM

    john's Avatar

    I just heard back from my contact.

    She says "Option-drag works nicely for me under 3.0.52/Catalina 10.15.5".

    Still looking for someone other than Rougeux who is experiencing this problem.


  13. Support Staff 13 Posted by john on 30 Jan, 2021 01:31 AM

    john's Avatar

    Hi Rougeux,

    Just checking in. I haven't forgotten you.

    So far I've not had any reports of anyone else with your problem, which makes this hard to debug. Has there been any change in your situation? Any further clues?

    To be clear, the suggestion I made above about remapping the Option Key to Caps Lock was not intended as a proposed fix - even if it worked. When dealing with difficult to diagnose bugs, my strategy is just start shaking everything - turn other things on, turn other things off, try it upside down, try it in rainstorms on Tuesday, keep banging until SOMETHING changes. Any behavioral change is a potential clue. There must be some reason why this is affecting you and - so far - no one else.

    You don't have any accessibility features turned on (even by accident), do you?

    If anyone else out there installs 3.0.52 and discovered that option-drag stops working please respond to this thread!


  14. 14 Posted by rougeux on 30 Jan, 2021 01:36 AM

    rougeux's Avatar

    Thanks for checking in, John. I tried remapping my Caps Lock key and that did indeed work. Out of curiosity, I tried resetting that and tried both option keys independently. I found that the right key doesn't work but the left one does. So maybe there's a bug with just detecting the right key? I never tried this before because I'm left-handed and only ever used the right option key when duplicating nodes (left hand on the mouse, right hand on the keyboard).

  15. Support Staff 15 Posted by john on 30 Jan, 2021 02:40 AM

    john's Avatar

    Aha! I think you've found the problem!

    I would have thought that both keys would appear the same to code at the NodeBox level. But I googled and discovered that recent Mac operating systems DO have the ability to differentiate between left and right option keys.

    AND I just tried this myself and verified that ONLY THE LEFT OPTION KEY works for me as well. I am right-handed and have never once used the right option key, so I didn't notice this until now.

    It seems likely that when Frederik updated his option drag code, he only tested for the left option key, not both of them. Frederik, if you are still listening, can you please confirm?

    So it looks like you are not alone after all, Rougeux. You just happen to be the first left-handed user to try 3.0.52.

    Frederik no longer works on NodeBox on a regular basis, so it was a heavy lift getting him to do the 3.0.52 update. I will let him speak for himself, but even though this would be a simple fix, it may be some time before he can crank out a patch for this.

    There might be some way of remapping the right option key to the left option key. I looked for this, but so far have come up empty. There may be some third party software or hardware that could help. I'll keep looking.

    At least we know what the problem is now. And you can limp by using the the left option key - a real pain for a left-handed person, but at least it's an option.


  16. 16 Posted by rougeux on 30 Jan, 2021 02:44 AM

    rougeux's Avatar

    The perks of being left-handed! Glad we found the cause. Hopefully a fix comes some time in the future.

    It's disheartening to hear NodeBox is no longer regularly developed. I assumed this was the case due to the lack of updates. It's made such an impact on the way I work on my project and presented a lot of opportunities to me that would not have been available otherwise. I hope someday it gets back on a regular update schedule.

  17. Support Staff 17 Posted by john on 30 Jan, 2021 03:00 AM

    john's Avatar


    I just found one workaround.

    On Mac System Preferences, go to the Accessibility panel, choose Keyboard from the left scrolling menu, and turn on "Enable Sticky Keys".

    Once Sticky Keys is on, both option keys work to option-drag in NodeBox. You can click either key and then drag, or just click and drag as you normally would. I've never used Sticky Keys before, but it seems to work pretty well. I could see leaving it on all the time. You can turn off the clicking noise and visual indicators if they bother you.

    Let me know if this works for you, Rougeux.


  18. 18 Posted by rougeux on 30 Jan, 2021 03:02 AM

    rougeux's Avatar

    That's worth trying to see how it works out. Thanks for finding that and for all your help in sticking with this issue!

  19. Support Staff 19 Posted by Frederik De Ble... on 30 Jan, 2021 10:57 AM

    Frederik De Bleser's Avatar

    It seems the APIs for remapping keyboard shortcuts have been changed in the newer versions of Java — the old APIs are deprecated so I switched to the newer versions, but apparently they don't support keyboard remapping etc. The same issue happens with the "meta" key on Windows.

    I'll see if there's another way of accessing keys.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

25 May, 2024 11:52 AM
24 May, 2024 07:39 AM
16 May, 2024 02:11 AM
16 May, 2024 01:58 AM
14 May, 2024 01:29 AM


13 May, 2024 12:36 AM
12 May, 2024 07:46 PM
05 May, 2024 04:38 PM
03 May, 2024 06:50 AM
03 May, 2024 12:30 AM
03 May, 2024 12:09 AM