Export movie not working

atommic's Avatar


03 Jan, 2017 08:37 AM


I'm trying to export a movie but there is no saved movie file. I've tried several different formats and also tried rendering only 2 frames but nothing is working.
Would greatly appreciate help on this matter

Thank you :)

  1. Support Staff 1 Posted by Frederik De Ble... on 08 Sep, 2017 09:21 AM

    Frederik De Bleser's Avatar


    What platform are you running on? What version of NodeBox?

  2. 2 Posted by shanejez on 31 Jan, 2020 04:01 PM

    shanejez's Avatar

    I am also having this issue on the most current Nodebox 3. I am running on Mac.

  3. Support Staff 3 Posted by john on 31 Jan, 2020 08:21 PM

    john's Avatar


    Puzzling. I'm sorry you're having this issue.

    I export movies (on a Mac) on an almost daily basis without trouble. I spent a few minutes trying to think of anything I could to make this fail, but I got a movie every time.

    Is there any indication at all of trouble while the movie is rendering?

    When you choose "Export Movie..." from the NodeBox File menu you should see a dialog. You enter the frames (1 to100 is the default). If you change these values the second number must be greater than the first. If you try to make a movie from 1 to 0 or 5 to -5 no movie will appear.

    You can also change the format from MP4 Video to something else. Are you doing this? I tried other formats but they worked OK for me.

    For file you click the ... button to choose a file name and directory for the file to land in. If you fail to enter any information here your movie may land in an unexpected place. When I tried this NodeBox created a file called "Desktop.mp4" on my home directory ("john" in my case) - a place I rarely use and seldom look at (I store most of my working files on my desktop).

    Did you choose a specific file name and directory? Are you sure you looked in that same directory? If you have a distinctive file name you can search for it using Spotlight to be sure.

    When you hit the Export button you should see a progress indicator as each frame is rendered, then a second quicker progress indicator as the individual frames are stitched together into a single movie file. Is this what you saw?

    The file icon should then appear in whatever directory you asked it to. Did you see any error messages or anything else unusual?

    You are not out of disk space are you?

    Let me know if any of these questions reveal a possible cause. If not, try a different network. Quit Nodebox, relaunch, from the default app (a single rect node) choose Export movie, leave the defaults unchanged, click the ... button and set the file name to test and the directory to Desktop. Export the movie. Does test.mp4 appear on your desktop? Does anything unusual happen?

    Please try all this and let me know what happened.



  4. 4 Posted by shanejez on 19 May, 2020 02:51 PM

    shanejez's Avatar

    Hey John,

    Apologies for the massive delay in response. It has been an intense first year of my Graduate Architectural education after working in the professional world for over a decade.

    I will run a test and see if this issue still persists. I believe I have swapped to a new MacBook pro since having this issue and I am curious if it still occurs.

  5. Support Staff 5 Posted by john on 19 May, 2020 07:07 PM

    john's Avatar


    Turns out you were the first to notice that NodeBox has temporarily lost the ability to export movies under the latest OS (Catalina). Fortunately, there is a workaround; you can use the Export Range option and then stitch the frames together using a third party app like Quicktime.

    I posted details and some tips here:


    Frederik is aware of this problem and is working on a fix. In fact he has the fix working but is having some trouble getting an updated version of NodeBox certified. I hope we will see a patched version soon.

    Stay tuned!


  6. 6 Posted by shanejez on 19 May, 2020 09:24 PM

    shanejez's Avatar

    I am glad to hear I am not crazy -- haha!

    I will keep my ear to the ground.


  7. Support Staff 7 Posted by john on 15 Jan, 2021 03:28 PM

    john's Avatar

    GREAT NEWS! This bug has been fixed with version 3.0.52. You can download it here:


    Please download and give it a try. Let us know if you're still having any issues.


Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

29 May, 2024 05:47 AM
29 May, 2024 05:15 AM
29 May, 2024 05:12 AM
28 May, 2024 07:37 PM
25 May, 2024 11:52 AM


24 May, 2024 07:39 AM
16 May, 2024 02:11 AM
14 May, 2024 01:29 AM
12 May, 2024 07:46 PM
05 May, 2024 04:38 PM
03 May, 2024 06:50 AM