OS X NodeBox 3.0.43 crashes on startup

Szabolcs's Avatar

Szabolcs

17 Mar, 2015 11:56 PM

When I start NodeBox 3.0.43 on OS X 10.10.2, the Starting NodeBox window appears with a progress bar, then a second later it crashes. The crash report is attached.

I have Apple's java as well as 1.8.0_31 installed.

How can I fix this?

  1. 1 Posted by Szabolcs on 18 Mar, 2015 12:07 AM

    Szabolcs's Avatar

    I also get the attached crashlog in my home directory.

  2. Support Staff 2 Posted by Frederik De Ble... on 20 Mar, 2015 07:17 PM

    Frederik De Bleser's Avatar

    Hi,

    I've heard other people report problems on this before, but I can't reproduce it. Could you try creating a new user account on your Mac and starting NodeBox from there?

    Best,

    F

  3. 3 Posted by Szabolcs on 20 Mar, 2015 08:56 PM

    Szabolcs's Avatar

    I would rather not create an extra user account ... then I'd have to figure out how to cleanly remove it.

    But I have tested on a different Mac computer (2014 Mac Pro) and it crashes there as well.

    I can try to remove all settings if you let me know how (anything else than ~/Library/NodeBox?) Also, can I run NodeBox with some other Java version than the embedded one?S

  4. Support Staff 4 Posted by Frederik De Ble... on 20 Mar, 2015 09:09 PM

    Frederik De Bleser's Avatar

    Deleting an account is just a matter of removing the home folder. OS X will ask what to do when you press "delete". But I understand that you don't want to do that.

    The embedded version was created precisely so we won't have these issues :-) We don't want people to worry about Java, or if they have it installed.

    If you're handy with the Terminal you could try running it from there. You need Xcode and Homebrew installed. Then:

    brew update
    brew install maven ant 
    git clone https://github.com/nodebox/nodebox.git
    ant run
    

    I'll look into the crash logs next week.

  5. 5 Posted by Szabolcs on 20 Mar, 2015 09:22 PM

    Szabolcs's Avatar

    I tried a new account. It doesn't crash there. Does this give any hints about what I need to do to make it run on my main account?

  6. 6 Posted by Szabolcs on 20 Mar, 2015 09:31 PM

    Szabolcs's Avatar

    I should note that the previous version I had, 3.0.3x, did run without problems. But unfortunately I deleted that one ... Is there a way to download older versions?

  7. Support Staff 7 Posted by Frederik De Ble... on 20 Mar, 2015 09:33 PM

    Frederik De Bleser's Avatar

    That’s why I asked about the account – I’ve seen this with other people as well. Not yet sure why that is….

    Here’s a link to all downloads:

    https://secure.nodebox.net/downloads/

    Best,

    F

  8. 8 Posted by Szabolcs on 24 Mar, 2015 07:01 PM

    Szabolcs's Avatar

    Frederik,

    I tried your suggestion of cloning the github repo and executing `ant run`. It does not crash when run this way.

  9. 9 Posted by Szabolcs on 24 Mar, 2015 07:04 PM

    Szabolcs's Avatar

    However, if I build the app with `ant dist-mac`, then try to run the app, it will crash the same again.

  10. Support Staff 10 Posted by Frederik De Ble... on 05 Apr, 2015 01:52 PM

    Frederik De Bleser's Avatar

    That's really weird! The dist-mac command is what we use to build NodeBox as well. Again, does dist-mac work on a newly created user account?

    Best,

    F

  11. 11 Posted by Szabolcs on 05 Apr, 2015 02:47 PM

    Szabolcs's Avatar

    What I meant to say is this:

    `ant run` does run nodebox, and it does not crash.

    `ant dist-mac` does correctly build an application bundle. Running this application bundle crashes.

    I assumed that `ant dist-mac` will build exactly the same application bundle that nodebox.net carries, so this behaviour was not a surprise. The surprise was that `ant run` works, and suggests that the crash is due to how the app bundle is packaged.

    I did not use Homebrew, I installed the dependencies using MacPorts.

    What is it precisely that you need me to test on a fresh user account?

  12. 12 Posted by Szabolcs on 05 Apr, 2015 05:26 PM

    Szabolcs's Avatar

    Frederik,

    Would it at all help if I tested older versions to find out which is the oldest one that still crashes?

  13. Support Staff 13 Posted by Frederik De Ble... on 05 Apr, 2015 06:25 PM

    Frederik De Bleser's Avatar

    You could try that. I'm assuming it's the first one that bundles Java 1.8. (3.0.42, according to the release notes )

  14. 14 Posted by Szabolcs on 06 Apr, 2015 11:59 PM

    Szabolcs's Avatar

    3.41rc1 works, 3.41rc2 doesn't start at all (nothing visible happens) and 3.41rc3 crashes the same as 3.42 or 3.43.

    I notice that the app bundle structure is singificantly different between 3.41rc1 and 3.41rc3 or later. This could be a cause of the crash too ...

  15. Support Staff 15 Posted by Frederik De Ble... on 07 Apr, 2015 07:09 AM

    Frederik De Bleser's Avatar

    3.0.41-rc1 doesn't bundle Java 8 yet, whereas, starting from 3.0.41-rc3, we did bundle Java 8. This is necessary since Apple didn't include Java anymore in newer versions of OS X, and also removed the "auto-install" option.

    The app bundle is different since we're using Oracle's own Appbundler in the latest release, which should do a proper job of bundling Java 1.8. For most users, this works without a hitch, so I'm not really sure why it would be different in your case.

  16. Support Staff 16 Posted by Frederik De Ble... on 07 Apr, 2015 07:10 AM

    Frederik De Bleser's Avatar

    Okay, wild hunch, but could you try putting it in a folder without spaces? I noticed from the crash report you put NodeBox in the "Applications/Generate Art" folder; I've found that spaces in the name could cause weird errors. I'm wondering if they have anything to do with it.

  17. Support Staff 17 Posted by Frederik De Ble... on 07 Apr, 2015 07:12 AM

    Frederik De Bleser's Avatar

    Also, does your user name, or use directory, have any non-ASCII, accented characters?

  18. 18 Posted by Szabolcs on 07 Apr, 2015 08:13 PM

    Szabolcs's Avatar

    No, there are no special characters. It's not due to the spaces either (it crashes regardless of location).

    So what else could it be?

    You mentioned that others complained too.
    For me it crashes on two different computers.
    It could be a conflict with something that's installed? I do have a JDK installed, but I'm not sure how to remove it fully. Deleting /Library/Java/JavaVirtualMachines/jdk1.8.0_40.jdk/ doesn't fix the problem. I also have Apple's Java installed because actually OS X Yosemite still prompts to install it if programs need it, and there are a few I use that do need it. I also have MacPorts, but it's supposed to keep the system unmodified except for /opt/local, so I don't see how it would cause a conflict (applications don't see the PATH I set in my .profile, so shouldn't be able to see MacPorts).

    It also seems that NodeBox will only crash when running it app bundle. ant run won't crash.

    A final piece of information: the I tested 3.41rc1, just before the crash a window came up showing some Java errors (not the usual OS X crash report). It was only a split second, so I couldn't see what was there. The crash happens only just before the main NodeBox window would come up, the startup progress bar is still displayed after starting the app.

  19. 19 Posted by Szabolcs on 07 Apr, 2015 08:19 PM

    Szabolcs's Avatar

    Well, I managed to capture a screenshot of that Java error before it disappeared. This is wit 3.41rc3 (not rc1 as I wrote above, that was a mistake). Right after showing this it crashes.

  20. Support Staff 20 Posted by Frederik De Ble... on 08 Apr, 2015 07:18 PM

    Frederik De Bleser's Avatar

    Thanks for looking into this. Unfortunately this refers to a bug that
    was already fixed (https://github.com/nodebox/nodebox/commit/5645463e9b2149c34ab59bc8f6bfa4d0b0c4899b).

    Reading through the crash report again, it seems that Java has an issue
    with locales. What locale is your system set in?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • crashreport.txt 89.6 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac

Recent Discussions

15 Jul, 2024 07:37 PM
11 Jul, 2024 03:48 PM
28 Jun, 2024 01:51 PM
27 Jun, 2024 02:56 PM
27 Jun, 2024 01:57 PM

 

26 Jun, 2024 08:17 PM
26 Jun, 2024 11:35 AM
24 Jun, 2024 02:42 AM
24 Jun, 2024 12:46 AM
23 Jun, 2024 08:07 AM
08 Jun, 2024 09:05 AM